DNS errors in the event log of the PCoIP Zero Client running firmware 5.x and 6.x.
Problem
The PCoIP Zero Client event log contains these entries ever 5 minutes.
-510 MGMT_DISC_DNS :conduct_dns_record_search: (DNS SRV: CMS) DNS record not found
-510 MGMT_DISC_DNS :conduct_dns_record_search: (DNS SRV: Config Tool) DNS record not found
-510 MGMT_DISC_DNS :conduct_dns_record_search: (DNS SRV: VCS) DNS record not found
Cause
The DNS SRV part of the log file has changed from older firmware versions. The default configuration of a PCoIP Zero Client has DNS SRV enabled by default. This is configured in the AWI under Configuration, Discovery. This can also be set via the PCoIP Management Console.
DNS SRV discovery checks for 3 things every 5 minutes by default:
-510 MGMT_DISC_DNS :conduct_dns_record_search: (DNS SRV: CMS) DNS record not found
-510 MGMT_DISC_DNS :conduct_dns_record_search: (DNS SRV: Config Tool) DNS record not found
-510 MGMT_DISC_DNS :conduct_dns_record_search: (DNS SRV: VCS) DNS record not found
DNS SRV: CMS - This is for a Connection Management Server. This functionality has been deprecated in Firmware 5.x and newer. This message will be updated in a future release.
DNS SRV: Config Tool - This is for the Management Console. If using DNS SRV for discovery of PCoIP zero clients or PCoIP remote workstation cards then you would normally set a DNS 'A' record, a DNS 'PTR' record and a DNS 'SRV' record for the Management Console.
DNS SRV: VCS - This is for the View Connection Server. Typically used in VMware Horizon View environments and set as an optional record.
For more details on each of these please see What are the DNS SRV records supported by PCoIP Zero Client and PCoIP Remote Workstation Card firmware?.
Resolution
To prevent these error messages from showing up in the event log, go to the Web interface of the PCoIP Zero Client and disable DNS SRV Discovery. This can also be set by Profile application in the Management Console.
The DNS SRV record, if set in DNS, will still work and advise the PCoIP Zero Client of the correct PCoIP Management Console to talk to.