How do I reset a forgotten password? What should I do if I have forgotten both my ID and password?

Rate this Article
Average: 1 (2 votes)

How to reset my password?

In various scenarios, you might need to reset your password. Follow the steps below to reset your password:

  1. Click the "Login" button on HP Anyware Support Portal home page.
  2. Click the "Forgot your password?" button below "Log in" button.
  3. On the PASSWORD RESET form, enter your email address, then click the "Send Password Reset Email" button.
  4. Click the link in the password reset email, click "Reset Password" on the page, and in the "Change Your Password" form, enter your new password, then submit it by clicking "Change Password".

 

What should I do if I have forgotten both my ID and password?

You login ID is your email address.

Scenario:

What if I have multiple email addresses, and I am not sure which email address has been registered, what should I do?

Resolution:

Try following the above steps to reset the password with the email address in question, if you can receive password reset emails, then that email address has been registered.

 

What should I do if the password reset email was not received?

Possible Cause:

The email address has not been registered yet. Or the password reset email might be filtered into spam folder.

Resolution:

  • First check the Spam folder.
  • If there is no password reset email in Spam folder, and you would like to register with that email address, try self-register with the email address (refer to how to create an account for details).
  • If it's still not working, submit a Customer Service Inquiry “Account Management” ticket to HP Anyware: https://help.teradici.com/s/customer-service.

 

What should I do if the password reset link does not work?

When you click the password reset link from your email, it brings you to the same "PASSWORD RESET" page again.

Possible Causes:

The reset password link has expired.
There are two scenarios that could cause a Reset password link to be expired.

Scenario 1:

24 hours have passed from the time the password link was requested.

Resolution:

Reset your password again, and click the reset password link within 24 hours.

Scenario 2:

The email server protection software might have automatically expired the link by previewing it.

 

Known Software (that can cause the password reset link to expire):

  • McAfee feature 'Link Protect'
  • Outlook all versions (corrupted rules)
  • Mimecast Anti-spoofing software
  • Covenant Eyes - Internet Filtering

Resolution:

  • Submit a Customer Service Inquiry “Account Management” ticket; Or
  • Contact the support of the email server protection software to have them whitelist emails coming from Salesforce or reach out to the internal department that manages the software.