License Activation with the PCoIP Management Console 2.x and 3.x fails with "ERROR: flxActAppActivationSend - (50041,41143,34)"
Problem
License activation is failing with:
[root@localhost admin]# /opt/teradici/licensing/mc_activate_lic.sh -k 1234-5678-90AB-CDEF
Activation Failed. Please verify your activation key.
Running with debug output enabled (-d TRUE) may be helpful.
[root@localhost admin]# /opt/teradici/licensing/mc_activate_lic.sh -k 1234-5678-90AB-CDEF -d TRUE
----------Debug output start-----
Command executed:
/opt/teradici/licensing//appactutil -served -comm soap -commServer https://teradici.flexnetoperations.com/control/trdi/ActivationService -entitlementID 1234-5678-90AB-CDEF ""
Detail output:
Generating activation request using:
Entitlement ID = 1234-5678-90AB-CDEF
Expiration = 31-dec-2020
Status: 4, Creating request
Status: 5, Request created
Status: 6, Context created
Status: 0, Error
ERROR: flxActAppActivationSend - (50041,41143,34)
----------Debug output end-------
Activation Failed. Please verify your activation key.
Running with debug output enabled (-d TRUE) may be helpful.
Cause
50041,41143,34 indicates the licensing system was unable to communicate to the license servers. For license activation to work, the system must have access to teradici.flexnetoperations.com on TCP port 443. Ensure the environment is configured to allow access.
Resolution
The PCoIP Management Console can be licensed in 3 ways:
- Online with access to the internet to communicate over TCP port 443 with the licensing server.
- Online via a proxy server. The PCoIP Management Console can be configured to use a proxy server. Consult the Administrators' guide for your release for more information.
- Offline via shortcodes. This feature is available in PCoIP Management Console 3.0 and newer. Consult the Administrators' guide for your release for more information.
Note: Online activation communication is only required for activation and deactivation of licenses. It is not required for general operation.
When using the online method you can use the following steps to check communication to the license server.
- SSH into the Management Console or use the ESXi Console and login.
-
At the prompt [admin@mypcpoipmc ~]# enter one of the following commands
wget https://teradici.flexnetoperations.com/control/trdi/ActivationService
Note: wget may need to be installed.
curl https://teradici.flexnetoperations.com/control/trdi/ActivationService
- These commands will reach out to the activation server and respond with:
wget:
[admin@mypcoipmc ~]# wget https://teradici.flexnetoperations.com/control/trdi/ActivationService
--2015-10-19 22:39:53-- https://teradici.flexnetoperations.com/control/trdi/ActivationService
Resolving teradici.flexnetoperations.com... 64.14.29.85
Connecting to teradici.flexnetoperations.com|64.14.29.85|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ActivationService
[ <=> ] 117 --.-K/s in 0s
2015-10-19 22:39:53 (11.7 MB/s) - ActivationService
[admin@mypcoipmc ~]#more ActivationService
<h2>{http://www.macrovision.com/fnp/2004/11/activation}activationPort</h2>
<h3>Hi there, this is a Web service!</h3>
[admin@mypcoipmc ~]#
curl:
[admin@mypcoipmc ~]#curl https://teradici.flexnetoperations.com/control/trdi/ActivationService
<h2>{http://www.macrovision.com/fnp/2004/11/activation}activationPort</h2>
<h3>Hi there, this is a Web service!</h3>
As you can see in the above responses we were successful in connecting to the licensing server. The result retried is the expected "Hi there, this is a Web service!". If you receive a different result, your connection may be being intercepted by a proxy server or firewall.
If you are not successful in connecting to the licensing server then you will need to troubleshoot your network to see where the connection is being blocked.
Some probable causes are:
- Firewall
- Antivirus software
- Port blocking on your routers
- Blocked TCP/UDP ephemeral ports.