When connecting to the PCoIP Graphics Agent I only get 1 display when I have 2 or more connected
Problem
When connecting to a PCoIP Graphics Agent installed on a machine with an Nvidia GRID K340, Nvidia GRID K520, Nvidia GRID M series or above GPU I only get one display but the PCoIP Zero Client or PCoIP Software Client has multiple displays attached. Not all of the displays connected to the PCoIP Client are working.
Cause
Nvidia GRID K340 and K520 GPU's are limited to one GPU per a display.
With the introduction of the Nvidia GRID M60, M6 and newer, a license is required from Nvidia to use the GPU for tasks such as Virtual Workstations. Without the license the GPU is limited to 1 display and a maximum resolution of 2560x1600.
Resolution
If using a Nvidia GRID K340 and K520 GPU add multiple GPU's or switch to a GPU that supports more than 1 display.
For the Nvidia GRID M60, M6 or newer, verify that the Nvidia driver obtained a license from the Nvidia license server.
Linux
Execute the following command and verify a license was acquired.
sudo grep gridd /var/log/messages
Aug 5 15:40:06 localhost nvidia-gridd: Started (4293) Aug 5 15:40:24 localhost nvidia-gridd: License acquired successfully.
If there are issues you may receive an output such as below.
Dec 6 13:55:29 localhost nvidia-gridd: Started (591) Dec 6 13:55:32 localhost nvidia-gridd: Configuration parameter ( ServerAddress ) not set Dec 6 13:55:32 localhost nvidia-gridd: Configuration parameter ( FeatureType) not set Dec 6 13:55:32 localhost nvidia-gridd: Shutdown (591)
Please consult the Nvidia documentation for more information and troubleshooting.
https://images.nvidia.com/content/grid/pdf/GRID-Licensing-Guide.pdf
If the system successfully obtained an Nvidia license please open a ticket with Teradici Global Support Services for further investigation.
Windows
Open the Nvidia Control Panel and navigate to Licensing, Manage License in the left hand pane. On the right hand side ensure the system has obtained a license.
Please consult the Nvidia documentation for more information and troubleshooting.
See also: