Why does an EDID read failure cause my display attached to the PCoIP Zero Client to using a lower resolution than expected.
Problem
The monitor attached to the PCoIP Zero Client is using a resolution much lower than expected.
The attached devices on the AWI \u2192 Info \u2192 Attached devices show EDID read failure.
The Display Topology section in the zero client log file shows the following:
Monitor Port 1:
Display State: Connected - EDID read failure
Display Name: TERA DEFAULT
Serial Number: 000000000000
Manufacturer Name: XXX
ID Product Code: FFFF
Native Resolution: 1024x768 @ 60 Hz
Current Resolution: 1024x768 @ 60 Hz
Background
EDID stands for Extended Display Identification Data. It is a collection of data provided by a digital display to describe itself and its capabilities, including manufacturer name and serial number, product type, timings supported by the display, display size, etc.
Using the EDID of a display, a PCoIP Zero Client can determine what kind of monitor(s) are connected to it. Upon session connection, all Display Topology information is forwarded to the host endpoint. On DVI connected displays, the EDID is read through dedicated DDC (Display Data Channel) lines using I?C (Inter-Integrated Circuit) protocol. On a DisplayPort monitor, the EDID is received using the AuxChan protocol. EDID is defined by a standard publication by the Video Electronics Standards Association (VESA).
Cause
The reason for EDID data not being read correctly through a DVI cable is usually:
- A poorly connected cable.
- Bad or poorly manufactured video cable
- An issue in the end unit male connector.
- Corrupted or erased EDID on the display.
When a zero client fails to read an EDID correctly, the zero client will assign \u201CTeradici Default\u201D display settings to the attached display, thus allowing the display to be operated in a minimal capacity.
These settings are:
- Timing \u2013 60 Hz
Resolutions available:
- 1280x1024
- 1024x768 (generally default)
- 800x600
- 640x480
Resolution
EDID read failures are typically signal issues. Try the following:
- Power off both the PCoIP Zero Client and Monitor by disconnecting them both from the wall. The I2C chip on both sides can be powered by the other device over DVI. If a chip is is a bad state, the only way is do a full power cycle of both devices.
- Remove the DVI or DP cable, reconnect and screw in both ends. In a DP cable with a press button release give a cable a light tug to ensure it has locked in place.
- Repace the display cable. Some DVI cables have been found to not full comply with specification.
- Try a different monitor.