Why is my virtual desktop experiencing poor display or video performance after installing or updating VMware software?
Scenario
Your virtual machine (VM) may experience some of the following performance issues after updating or installing VMware tools, VMware View agent, or PCoIP software:
- Poor video playback.
- Slow windows drag within one monitor or between two monitors.
- Slow window drag across monitors.
- Slow frame movement.
- Slow typing.
- Slow window display.
- Poor audio/video lip-sync.
- Black screen.
If a full power down between install steps has NOT been performed, there is a high chance of unsatisfactory display performance.
Cause
In a new or existing View environment, updates to the VMware Tools, VMware View agent, or PCoIP software can affect the SVGA drivers (video driver) ability to function properly.
Note: We have also observed that performance is degraded when 3D is enabled on the pool but the Windows Aero components are not activated within the VM.
Resolution
Re-install software if there is poor video performance. Steps below must be done in the following order and include a hard power off of the VM after each step to ensure success.
- Uninstall the VMware Tools and View Agent software;
- Install VMware Tools;
- Power off the VM;
- Power on the VM;
- Install the VMware View Agent (or install new VMware View agent if applicable);
- Power off the VM;
- Power on the VM;
- Install the APEX 2800 drivers (if applicable);
- Power off the VM;
- Power on the VM;
- Install the HP Anyware Audio Driver (if applicable);
- Power off the VM;
- Power on the VM.
Note: The APEX driver must be re-installed in APEX environments, followed by another power off and power on of the VM machine.
Note: Power off the VM means the VM must be shutdown and powered off and not just rebooted.
3D and Windows Aero: If you are using VMware's 3D option on your pool and want to avoid performance issues (see note further above) perform the following:
Note: Also, make sure that you have the correct virtual hardware version for your version of Windows. See VMware documentation for View 5.0 for further details here. |
Similar details have been noted in VMware knowledge base articles 2039529 and 2004754:
- http://kb.vmware.com/kb/2039529 - Connecting to a View Desktop using PCoIP fails with a black screen
- http://kb.vmware.com/kb/2004754 - Installing VMware Tools in vSphere
See also:
What should video playback expectations be in a PCoIP session?